WordPress 5.0: Qué hay de nuevo

Blog

20 noviembre 2018

WordPress 5.0: Qué hay de nuevo

La fecha del lanzamiento de WordPress 5.0 cada vez está más cerca. Es posiblemente una de las mayores actualizaciones de los últimos años, y seguro que ya has oído hablar de ella. Pero ¿qué trae de nuevo esta versión?

WordPress 5.0: ¿qué trae de nuevo?

La novedad se centra en el completamente renovado editor de WordPress que han denominado Gutenberg. El hasta ahora editor clásico de WordPress que viene por defecto te ofrece una seria de botones para editar y dar forma a tu contenido limitado a estilos de párrafo, enlaces y poco más.

El nuevo editor Gutenberg se basa en bloques y te da mayor libertad para insertar contenido, reorganizar y crear distintas composiciones en tu página con una interfaz mucho más visual que hasta ahora. Este será el aspecto del editor de WordPress:

También puedes probarlo tú mismo.

¿Es necesario utilizar Gutenberg?

Las nuevas instalaciones de WordPress vendrán con Gutenberg de serie, junto con el tema Tweenty Nineteen. Pero será posible instalar el plugin de Editor clásico si quieres seguir utilizándolo. WordPress se ha comprometido a mantenerlo, pero sólo por un tiempo. Por ello familiarizarse con Gutenberg será necesario, antes o después. Si decides utilizar Gutenberg, el contenido que ya tengas creado con el editor clásico se mantendrá tal y como es, aunque te permitirá convertirlo en bloques.

¿Cuándo está previsto su lanzamiento?

Después de muchos cambios, parece que la nueva versión verá la luz el próximo 27 de Noviembre.

¿Puede romper algo esta actualización en tu web?

Siendo una actualización mayor, siempre es recomendable hacer una copia de seguridad por si algo sale mal. Por otro lado, te recomendamos que compruebes si tienes activada la actualización automática, para estar prevenido. De todas manera, también puedes testear en un entorno de pruebas en primer lugar y comprobar que todo funciona correctamente o existe algún problema. Es probable que existan incompatibilidades con el tema y los plugins que  utiliza tu web. Es mejor asegurarte primero. Woocommerce ya ha anunciado que necesitas como mínimo la versión 3.5.1+ para que funcione en WordPress 5.0

 

En resumen

WordPress 5.0 es una de los mayores actualizaciones de los últimos tiempos. La forma en que creamos contenido en el editor va a cambiar, y también afectará al desarrollo de plugins y temas que ya tienen funcionalidades similares para la construcción. Solo con el tiempo veremos cómo nos adaptamos a este nuevo cambio.


20 de noviembre de 2018|

Deja un comentario

Usted declara ser mayor de dieciocho años y consiente el tratamiento de sus datos por HispaVista S.L. para la recepción de comunicaciones comerciales y de cortesía relacionadas con nuestra entidad según lo establecido en nuestra Política de privacidad